Jmeter-to-k6 on windows

Hi,

On Windows downloaded “github.com/loadimpact/jmeter-to-k6” zip folder and installed nodejs and npm. When tried to convert getting error message. When tried to convert sample jmx files getting below error message.

node jmeter-to-k6.js C:\Users\hhanumanthappa\Documents\CSVDataSet.jmx -o C:\Users\hhanumanthappa\Documents\Ck6\test.js

Error:
(node:27288) UnhandledPromiseRejectionWarning: Error: EPERM: operation not permitted, symlink 'C:\Users\<<path>>\Downloads\jmeter-to-k6-master\jmeter-to-k6-master\node_modules' -> 'C:\Users\<path>~1\AppData\Local\Temp\tmp-27288vk7HpwHHQYPs\node_modules'
(Use `node --trace-warnings ...` to show where the warning was created)
(node:27288) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode). (rejection id: 1)
(node:27288) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

thanks

a quick google searched lead me to:
Windows: EPERM: operation not permitted, symlink · Issue #1969 · lovell/sharp · GitHub and how can use sharp in lambda function (OS: window10 , severless) · Issue #1671 · lovell/sharp · GitHub which suggest that either you are running on fat32 or that you need root cmd to run the command for some reason, not a windows user :man_shrugging: .

I would recommend using the docker image and if there are any more errors, it might be better to just open an issue with the jmeter-to-k6 project