X509: certificate signed by unknown authority

I have started trying out k6 today and I am impressed.
I see a problem with https requests made to a test server.

WARN[0003] Request Failed error=“Get “https://127.0.0.1:4433”: x509: certificate signed by unknown authority”

it is self signed certificate. I don’t want disable the tls verify. Because we are testing tls 1.3 testing
please help me with this guys
Thanks in advance

Hi there, welcome to the forum :slight_smile:

If you don’t want to run with --insecure-skip-tls-verify, I think your only option is to add the root CA certificate to your local store.

On Linux this would involve the ca-certificates package and copying your cert to the correct location. This will be system dependent, but see the instructions for Ubuntu, otherwise consult your OS documentation.

Hope this helps,

Ivan